Go Back   Nodiatis Forums > Nodiatis Forums > General Discussion > Bug & Exploit Reports
RECOVER | REGISTER

Reply
 
Thread Tools Display Modes

Sound stops working after sitting in town for a while
Old 12-29-2019, 09:38 PM   #1
Lakki
Gem Pouch Expert
 
Lakki's Avatar
 
Lakki is offline
Join Date: Dec 2012
Location: Arizona or anywhere sandy!
Posts: 342
Post Sound stops working after sitting in town for a while

https://ibb.co/hFbKND1


Sat in town 2 and did nothing except queue for arena. Eventually my sound stopped working.

I closed the debug window as I thought it didn't have any detrimental effect on gameplay.

Was sitting at my pc reading something, ended up losing a match by being AFK because my gong didn't go off. I then PM'd a bunch of nodders, and sure enough my sound wasn't working after that debug thing popped up. I wasn't receiving the PM sound either.

I also pulled up my volume mixer to be sure that my sound was turned on, and yes it was, but the "Lakki" window completely disappeared from the volume tabs, as if my PC completely doesn't recognize the window.

https://ibb.co/hm3x3p9

The simple solution was just simply restarting the client, and the sound comes on perfectly again. And it even shows up here on the volume mixer But i'm wondering what causes the sound to randomly stop working? Is it just from using the client for too long? Or did my PC just completely give up on using sound from the client after a while.
https://ibb.co/wWG0dg7

I have no idea if i'll be able to replicate the bug again, But I will let you know if it happens again
  Reply With Quote

Old 12-30-2019, 01:52 AM   #2
Glitchless
Administrator
 
Glitchless's Avatar
 
Glitchless is offline
Join Date: May 2008
Posts: 8,502
Default

Need to know when the debug window popped open and what possibly could have been the bad sound that triggered it.
__________________
Computing the probability that at least one of the following events will occur:
P(a or b ... or z) = 1 - P(!a and !b ... and !z)
Probability
  Reply With Quote

Sound Issue
Old 01-06-2020, 03:52 PM   #3
Lakki
Gem Pouch Expert
 
Lakki's Avatar
 
Lakki is offline
Join Date: Dec 2012
Location: Arizona or anywhere sandy!
Posts: 342
Post Sound Issue












Seems to happen when I sit idle for too long. Whenever I receive Private Messages, or enter combat against enemies, I cannot hear anything. This will be resolved by me closing and reopening the client, However the developer/debug menu seems to say that it's "Attempting to reset sound system" , but nothing happens, and I still remain unable to hear anything.

I PM'd Roeth, he pm'd me back, and I didn't get the sound, after closing the developer window.

  Reply With Quote

Old 01-07-2020, 12:49 AM   #4
beetdabrat
Auction Master
 
beetdabrat's Avatar
 
beetdabrat is offline
Join Date: Mar 2009
Posts: 1,086
Default

Are you using hdmi, blue tooth or a usb headset by chance?
__________________

  Reply With Quote

Old 01-07-2020, 01:03 AM   #5
Glitchless
Administrator
 
Glitchless's Avatar
 
Glitchless is offline
Join Date: May 2008
Posts: 8,502
Default

Pretty sure it's an issue with the OS putting sound hardware to sleep, the client losing access and not reestablishing it gracefully. That may not be fixable since we specifically use a very old Unity version to compile the game so that it runs on older windows computers.
__________________
Computing the probability that at least one of the following events will occur:
P(a or b ... or z) = 1 - P(!a and !b ... and !z)
Probability
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:15 AM
Boards live since 05-21-2008


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.